TMNT : Turtles in Time - Konami

Publié le par Seb

Un "Teenage Mutant Ninja Turtles : Turtles in Time" confié par MSX33.
 
Le jeu est subitement devenu silencieux et les contrôles ont cessé de répondre (en dehors des crédits et du service).
 
MSX33 est en deuil !
 
La PCB est très propre et il n'y a aucune trace de réparation antérieure :
Je commence par vérifier la présence de 5V sur les contrôles au niveau du connecteur JAMMA -> Rien à signaler de ce côté...
 
Je dégaine ensuite le schéma de la PCB.
Un gros merci à tous ceux qui partagent leurs schémas sur le net !! Vous avez pas idée de l'aide précieuse que cela nous apporte.
 
Je regarde le circuit d'encodage des contrôles :
 
ils arrivent directement sur des petits custom Konami estampillés "005273" :
 
Puis à la sortie de ces "005273", une grande partie des signaux vont sur des 74253 (multiplexeurs) et ceux qui restent, vont sur des 74257 (autre type de multiplexeurs)

 

 
Je sonde les 74253 à l'oscilloscope pour trouver d'éventuelles anomalies... Voici sur quoi je tombe en sondant leurs pin 2 (entrée Select B) :
Le signal reste bloqué en haut...
 
Je trace le circuit du "Select B" des 74253 sur le schéma :

... Et je tombe sur la sortie d'un 7407 (tampons/pilotes) emplacement 13H !

 
 
Les contrôles de crédit et de service fonctionnent encore car les autres sorties du 7407 ne sont pas affectées par la panne. Une autre de ses sorties contrôle le "Select A" des 74253, et le "Select" des 74257 (1 seul Select pour les 74257 / Select A&B pour les 74253).
 
Mais pourquoi il n'y a plus de son me direz-vous ?
 
La raison est écrite ici noir sur blanc :
"SOUND"
 
La sortie 4 du 7407 pilote non seulement les multiplexeurs qui encodent les entrées des contrôles, mais aussi une partie du circuit audio.
Malheureusement le schéma est incomplet et il manque la page "subtitle : 06" qui concerne le circuit son de la PCB. Je ne pourrais donc pas vous donner plus de détails.
 
 
Retour à la pratique : je dessoude le 7407 et le test sur le Xeltek 610P :
Comme prévu il est HS !
 
Je le remplace et lance un test :
 
Tout est rentré dans l'ordre !
 

Publié dans Arcade

Pour être informé des derniers articles, inscrivez vous :

Commenter cet article

grumly 06/06/2019 09:48

Super intéressant comme article !
Par contre des multiplexeurs PORTUGAIS sur une PCB japonaise, c'est bizarre non ?
En tout cas MSX33 va pouvoir danser le gambadou maintenant :)